ClusterControl Daily digest is almost never generated and sometimes I receive an empty email with subject =?UTF8?Q??=

Comments

3 comments

  • Avatar
    Ashraf Sharif

    Hi Dirk,

    We haven't encountered such issue. Would you share a bit of your mail server configuration so we can try to reproduce this?

    From cmon_X.log (where X is cluster ID), you should see the following line if ClusterControl manages to send out an email:

    2019-11-01T07:22:45.007Z : (INFO) Mail Server: Got 250 (ok): '250 OK id=1iQRGd-00DNhx-Fy'

    Do you have any access to the mail server log? You can use the mail ID retrieved from cmon_X.log and use it to track the mail in the mail server log.

    Regards,
    Ashraf

    0
    Comment actions Permalink
  • Avatar
    Schippers Dirk

    Also, if I look at the cmon - logs and search for Mails being sent, there is no daily log line for sending the digest mails, where CluCo is configured to send a daily digest mail...

    $ cat /var/log/cmon_2.log* | grep Mail | grep '2019-11-05' -> 2019-11-05T07:00:27.344-01:00 : (INFO) Mail Server: Got 250 (ok): '250 2.0.0 Ok: queued as 43E8BE04B9'

    $ cat /var/log/cmon_2.log* | grep Mail | grep '2019-11-04' -> no results

    $ cat /var/log/cmon_2.log* | grep Mail | grep '2019-11-03' -> no results

    $ cat /var/log/cmon_2.log* | grep Mail | grep '2019-11-02' -> no results

    $ cat /var/log/cmon_2.log* | grep Mail | grep '2019-11-01' -> no results

    ...

    Daily digest has been configured for months (problem has always been there)

    0
    Comment actions Permalink
  • Avatar
    Ashraf Sharif

    Hi Dirk,

    After an extensive debugging, we have found the root cause of this issue and a fix will be coming soon, probably in the upcoming maintenance patch at the end of the week.

    I'll let you know when it's available. Thanks for reporting this.

    Regards,
    Ashraf

    1
    Comment actions Permalink

Please sign in to leave a comment.

Powered by Zendesk