host is swapping?

Comments

5 comments

  • Avatar
    Bart Oles

    Hi Bob,

    The swapines advisor is checking if you have it set to 1 which is a recommended value for database servers. If you have some grant issues on the server and would like to disable that you can go to Cluster->Performance->Advisor and disable it there.
    Please see the
    attached screenshot. 

     

    Kind regards,
    Bart

  • Avatar
    bob bob

    I have no write permissions to /proc/sys/vm/swappiness?

    even though:

    -rw-r--r-- 1 root root 0 Nov  5 13:01 swappiness

  • Avatar
    bob bob

    lsattr: Inappropriate ioctl for device While reading flags on ./swappiness

  • Avatar
    Ben M

    Using sysctl:

    sudo sysctl vm.swappiness=1

    To make it persist through a reboot, edit sysctl.conf:

    sudo nano /etc/sysctl.conf

    Add vm.swappiness=1 somewhere in there (bottom).

  • Avatar
    Ben M

    Hmm.. read about proxmox, not sure how it works and how containers work - closer to VMWare or Docker? Anyway, this article may be of assistance: Proxmox - Best performance - Disable swappiness

Please sign in to leave a comment.

Powered by Zendesk