Xtrabackup restore memory

Comments

4 comments

  • Avatar
    Bart Oles

    Hi Olof,

    I'm going to report this case to Cluster Control development team. In fact the backup-my.cnf contains only basic parameters to start the instance, the rest of parameters are provided via a flag or should be taken from [mysqld] or [xtradbbackup] sections for the restore. However, it may be that in your case the restore process is not checking for my.cnf instead it's running only on defaults. 

    BR,
    Bart

  • Avatar
    Olof Mattsson

    Hi,

    I've made sure that:

    [xtradbbackup]

    use-memory=2G

    Is present both on the server that the backup is taken from and on the server that runs the verification. But innobackupex still only uses the defaults in DATA_DIR/backup-my.cnf.

    The generated file needs to contain the option or it should be possible to pass options to the restore job from Clustercontrol.

    Brgds

    Olof Mattsson

     

     

  • Avatar
    Ashraf Sharif

    Hi Olof,

    Anyway, there was a typo suggested by Bart. It should be "[xtrabackup]" and not "[xtradbbackup]".

    I just also find it strange that the setting is not taken from my.cnf [xtrabackup] group. Anyway, we are going to improve this area by introducing an option in the UI so cmon could pass the value via --use-memory parameter to innobackupex during --apply-log stage.

     

    Regards,
    Ashraf

  • Avatar
    Olof Mattsson

    Hi,

    I already had a [xtrabackup] in all my.cnf with the use-memory set.

    We will be looking forward to the possibility to set use-memory. Currently a restore takes > 30 minutes with the default settings and that is too long.

    Brgds

    Olof Mattsson

Please sign in to leave a comment.

Powered by Zendesk