Failed to add replication slave.

Comments

8 comments

  • Avatar
    Johan

    Hi,

    do you have enough disk space on 10.10.2.186:/home/ec2-user ? 

    What AMI are you using and what instance size?
    Best regards

    Johan

     

  • Avatar
    Michael

    Should have plenty of disk space.

    Database is about 60GB.

    [ec2-user@ip-10-10-2-186 ~]$ df -h
    Filesystem Size Used Avail Use% Mounted on
    /dev/xvda1 99G 1.5G 97G 2% /
    devtmpfs 1.9G 64K 1.9G 1% /dev
    tmpfs 1.9G 0 1.9G 0% /dev/shm
    /dev/xvdb 197G 60M 187G 1% /data
    /dev/xvdc 197G 60M 187G 1% /backups
    [ec2-user@ip-10-10-2-186 ~]$


    Here is a copy of the slave configuration

    [mysqld]
    bind-address=0.0.0.0
    log_bin=binlog
    log_slave_updates=1
    expire_logs_days=7
    server_id=1001
    binlog_format=ROW
    slave_net_timeout=60
    basedir=/usr
    datadir=/data



    i am using an M3.Medium for EC2 Size.

     

  • Avatar
    Michael

    AMI is  amzn-ami-hvm-2015.03.0.x86_64-gp2 

  • Avatar
    Johan

    Thanks. will check.


    BR

    johan

  • Avatar
    Ashraf Sharif

    Hi Michael,

    I couldn't replicate the problem with the same setup. According to the innobackup.backup.log provided, you might encounter the same issue as described in this thread: https://www.percona.com/forums/questions-discussions/percona-xtradb-cluster/39187-nodes-don-t-join-after-upgrade-to-xtradb-cluster-5-6-22-72-0-and-xtrabackup-2-2-10

    Can you try to delete /data/.sst directory (on 10.10.2.186) and try again to add the slave from ClusterControl UI?

    Regards,

    Ashraf

  • Avatar
    Johan

    Hi Michael,

    If you on 10.10.2.186 do:

    nc -dl 9999 | xbstream -x -C /data

    and on 10.10.2.25 do:

    /usr/bin/innobackupex --host=127.0.0.1 --user=cmon --password=cmon --stream=xbstream /data/ 2>/home/ec2-user/s9s_tmp/1/galera/backup.log | nc 10.10.2.186 9999

    What do you get then?

     

    BR

    johan

  • Avatar
    Michael

    [ec2-user@ip-10-10-2-186 ~]$ nc -dl 9999 | xbstream -x -C /data
    nc: Address already in use


    [ec2-user@ip-10-10-2-25 ~]$ /usr/bin/innobackupex --host=127.0.0.1 --user=cmon --password=cmon --stream=xbstream /data/ 2>/home/ec2-user/s9s_tmp/1/galera/backup.log | nc 10.10.2.186 9999
    [ec2-user@ip-10-10-2-25 ~]$

     

     

    both commands run without error 



  • Avatar
    Michael

    Ashraf,
         The drive is empty

     

    [ec2-user@ip-10-10-2-186 data]$ ls -la
    total 8
    drwxr-xr-x 2 mysql root 4096 Jul 30 16:59 .
    dr-xr-xr-x 26 root root 4096 Jul 30 16:53 ..

Please sign in to leave a comment.

Powered by Zendesk