Too many logins from ClusterController into cluster nodes

Comments

7 comments

  • Official comment
    Avatar
    Johan

    Hi,

     

    Can you send a 

    "SHOW PROCESSLIST" 
    or

    select * from information_schema.processlist where user='cmon';

    From one of the affected db nodes?

    Also what cmon version are you using?

     

    BR
    johan

  • Avatar
    Alain Egho

    on an affected node:

    3250, 'cmon', '192.168.255.143:54914', 'information_schema', 'Sleep', 0, '', '', 115.361, 0, 0, 0.000, 67408, 0, 117062, '', 26803

    3249, 'cmon', '192.168.255.143:54864', 'information_schema', 'Sleep', 2, '', '', 2443.765, 0, 0, 0.000, 67408, 0, 117040, '', 29626

     

    cmon version:

    cmon, version 1.3.2.1391

     

    Thank You

    Alan

  • Avatar
    Johan

    Hi,

    Also please checkout this one (re: accounts-daemon):

    http://severalnines.com/blog/clustercontrol-tips-tricks-wtmp-log-rotation-settings-sudo-user

    A large wtmp file will cause the accounts daemon to act up b/c the accounts daemon is buggy and will try and re-read the wtmp fully as soon as a login / logout happens. If this then is a big file then the accounts daemon will eat cpu.

    This in turn could lead to connection issues.


    BR
    johan

  • Avatar
    Alain Egho

     hey guys after decreasing wtmp file size the accounts-deamon process cpu usage decreased!

     Use Log rotation for wtmp

    /var/log/wtmp {
        monthly
        create 0664 root utmp
        minsize 1M
        rotate 1
    }
     
    Regards,
    Alain

     

  • Avatar
    Johan

    Hi,

    Is the system then working for you again?

    BR
    johan

  • Avatar
    Alain Egho

    Hey

    cpu load droped dramatically after rotating logs

    I've been monitoring the process the logs are getting big quickly ,I Guess I should rotate logs every hour.

     

Please sign in to leave a comment.

Powered by Zendesk