installation on different ssh port

Comments

14 comments

  • Official comment
    Avatar
    Johan

    Hi,

     

    Can you try and do:

    ssh-copy-id -oPort=xxxx [ClusterControl IP address]

    However, you *must* also setup password less SSH between the controller and the data nodes you wish to use in the cluster. The above will only do it between the computer you are executing the command on and to the [ClusterControl IP address].

     

    THanks

    johan

  • Avatar
    Derek Fowler

    Hi, nope.. taht didnt work, still tires on port 22.. ( i have managed to do ths before, but cant for life of me remember how.. :(   )

     

  • Avatar
    Johan

    Hi.
    On what OS and version are you trying to execute the command on?

    BR

    johan

  • Avatar
    Johan

    For me it looks like this:

    ssh-copy-id -oPort=2222 10.10.10.10
    /usr/bin/ssh-copy-id: INFO: attempting to log in with the new key(s), to filter out any that are already installed

    /usr/bin/ssh-copy-id: ERROR: ssh: connect to host 10.10.10.10 port 2222: Connection refused

    When i have executed the cmd (now there is no sshd on port 2222, hence the conn refused).

  • Avatar
    Derek Fowler

    Im doing this...

     

    ssh-copy-id -i ~/.ssh/id_rsa [ClusterControl IP address] -p xxxx

    &

    ssh-copy-id -oPort=9898 101.101.101.1

    No identies found

     

    * I have created the key

  • Avatar
    Derek Fowler

    ps.. Im following this

    http://severalnines.com/getting-started

     

    on step 3

  • Avatar
    Johan

    Hi,

    Please double check you really have an identitiy file:

    ls ~/.ssh/id_rsa

    Else re-run

    ssh-keygen -trsa

    just press enter on any question (or 'yes' to overwrite in case of overwriting an existing).

    What output do you get from the ssh-keygen program? Can you paste it here (except any key data)?

    And then

    ssh-copy-id -oPort=9898 101.101.101.1



    BR

    johan

  • Avatar
    Derek Fowler

    Hi, had already done the renew key, but i`ll do it again..

     

    /root/.ssh/id_rsa already exists.
    Overwrite (y/n)? y
    Enter passphrase (empty for no passphrase):
    Enter same passphrase again:
    Your identification has been saved in /root/.ssh/id_rsa.
    Your public key has been saved in /root/.ssh/id_rsa.pub.
    The key fingerprint is:
    xx:xx:xx:xx:xx:xx:<rest snipped> root@xxxx.xxxx
    The key's randomart image is:
    +--[ RSA 2048]----+
    | .o o..oo |
    | * ... |
    | o o o |
    | + . + o |
    | = = E |
    | . = + o |
    | + . . |
    | o |
    | |
    +-----------------+

    [root@cluster ~]# ssh-copy-id -i -oPort=1886 xxx.xxx.xxx
    /usr/bin/ssh-copy-id: ERROR: No identities found
    [root@cluster ~]#

  • Avatar
    Derek Fowler

    sorry missed earlier Q.. this is on Centos6 64bit

  • Avatar
    Johan

    Hi,

    [root@cluster ~]# ssh-copy-id -i -oPort=1886 xxx.xxx.xxx
    /usr/bin/ssh-copy-id: ERROR: No identities found
    [root@cluster ~]#

     

    here you specify -i   , but no path to the file, so i believe that is why it complains.


    Please do (taking out the -i ):

    ssh-copy-id -oPort=1886 xxx.xxx.xxx

    Do you have different SSH ports on the different servers?

    BR

    johan

  • Avatar
    Derek Fowler

    Hi Johan, I had also specified the path  ~/.ssh/id_rsa

    & same  port on all servers

  • Avatar
    Alex

    Hi 

    What happens if you try

    $ ssh-copy-id "root@<host> -p 9898"


    Best Regards,

    Alex

  • Avatar
    Art van Scheppingen

    You could create/alter the ~/.ssh/config file on the host you are executing the ssh-copy-id from, and provide the port number in there with these lines:

    Host 101.101.101.*
    Port 1886

    The underlying ssh command would then use these settings to connect.

    BR

    Art

  • Avatar
    Derek Fowler

    right. bugger it, no joy..Im going to put port back onto 22 & figure it out later...

     

    Thanks anyway folks

Please sign in to leave a comment.

Powered by Zendesk